Heet

Het zal vast door het weer komen, maar mijn pc begint steeds meer kuren te vertonen. Vooral als het warm is, dan wordt de pc gevaarlijk heet. Bij het aanzetten begint het al met 60%, zodra ik een aantal programma’s openzet gaat het al naar de 70%. En als ik bijvoorbeeld een film kijk, dan kan het zomaar gebeuren dat het bios ingrijpt en de boel afsluit omdat de 80% grens bereikt is.

Hier moet dus wel iets aan gedaan worden, want werken met een open pc kast met daarop een ventilator gericht is ook niet alles. Aangezien de pc nu al weer 6 jaar oud is, is een nieuwe pc het beste. Gelukkig is mijn huidige monitor nog prima, dus die hoeft niet vervangen te worden. Daarom ben ik afgelopen weekend maar eens de stad in gegaan en mezelf getrakteerd op een spliksplinternieuwe pc. Wel nog met Vista, maar ook met een coupon voor een gratis upgrade naar Windows 7.

Eerder schreef ik al dat ik genoeg had van Ubuntu en op zoek zou gaan naar een andere distributie. Nu heb ik er voor gekozen om gewoon Windows te blijven gebruiken. Spelen met Linux doe ik dan via virtuele machines :).

Resetten Office key

Onlangs moest ik in Windows voor een Office installatie de licentie key wijzigen. Nu had ik alles kunnen verwijderen en opnieuw installeren, maar gelukkig is er een makkelijkere manier:

  1. open regedit (via Start > Uitvoeren > regedit)
  2. navigeer naar de volgende registersleutel:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\11.0\Registration\{90110407-6000-11D3-8CFE-0150048383C9}
  3. verwijder de volgende twee waarden:
    – ProductID
    – DigitalProductID
  4. start een onderdeel van Office en vul het juiste serienummer in

Backups van server

Iedereen is zich er denk ik wel van bewust dat het maken van backups erg belangrijk is. Maar het is ook iets dat er vaak bij inschiet. Belangrijkste in mijn geval zijn de websites en de achterliggende databases.

Voor de websites ga ik een keer per week een kopie maken en deze downloaden naar mijn eigen pc. De sites wijzigen qua structuur niet dagelijks, dus vaker dan eenmaal per week is niet nodig. Voor het maken van de archieven heb ik onderstaande scriptje in elkaar geknutseld.

#!/bin/sh
#
# Author:  Roland van der Veen
# Created: 14-07-2009 
#
# Variables
backupdir=/home/roland/backup/sites
date=`date +%Y%m%d`

# Make array for sites to backup
site=( site1.nl site2.nl site3.nl )
sitenum=${#site[@]}

# Make backups
for ((i=0;i<$sitenum;i++));
do
	 tar czf $backupdir/${site[${i}]}_$date.tar.gz -C /var/www/ ${site[${i}]}/
	 chmod 644 $backupdir/${site[${i}]}_$date.tar.gz
	 chown roland.roland $backupdir/${site[${i}]}_$date.tar.gz
done

Voor de databases is het een ander verhaal, hiervan moet elke dag een backup gemaakt worden die automatisch naar een andere server gestuurd wordt. Daar moet nog wat aan gesleuteld worden.

Postfix certificaten

Deze maand liep het clientcertificaat af dat ik gebruik voor het versturen van mail. Mijn vorige beschrijving was niet helemaal volledig. Er zijn nog een aantal stappen nodig:

  • root /etc/postfix# vi relay_clientcerts
  • root /etc/postfix# postmap relay_clientcerts
  • root /etc/postfix# /etc/init.d/postfix restart

Ubuntu 9.04 problemen met netwerk

Al sinds de upgrade van Ubuntu 8.10 naar 9.04 heb ik last van het feit dat na het opstarten er niet direct een internetverbinding is. Als ik vervolgens handmatig de netwerk daemon herstart, dan werkt het gewoon normaal.

Googlen levert – zoals altijd – genoeg resultaten, maar niet een was voor mij de oplossing.
Wel kwam ik erachter dat het waarschijnlijk veroorzaakt werd door de pakketten apparmor en avahi. Uiteindelijk heb ik er voor gekozen om beide pakketten maar gewoon compleet te verwijderen.

Geen mooie oplossing, maar het werkt wel. En apparmor en avahi zijn voor mij niet zo belangrijk, die kan ik best missen.

Ubuntu heeft afgedaan

Gisteren maar eens de upgrade uitgevoerd van Ubuntu 8.04 naar 8.10. En zoals ik vooraf eigenlijk al verwacht had, gebeurde precies hetzelfde als bij de vorige 3 updates van Ubuntu.

Wat is het geval? Ubuntu is niet in staat om een goed werkende 8.04 installatie bij te werken naar een goed werkende 8.10 installatie. Allereerst het updaten zelf, dat duurde ruim vier uur en dat is naar mijn idee veel te lang.

Ten tweede was na installatie mijn configuratie voor X weer eens vernaggeld. Blijkbaar kunnen Nvidia en linux niet goed samenwerken. Ik had een opstelling met twee monitoren, dit werkte goed. Echter, na de upgrade werd de tweede monitor niet meer herkend en op de eerste monitor had ik allerlei strepen door het beeld. Na veel prutsen en het uitproberen van allerlei drivers had ik opeens weer goed beeld. Weliswaar wordt de tweede monitor nog steeds niet herkend, maar dat laat ik maar even voor nu.

Daarnaast verwacht ik bij een upgrade dat er geen nieuwe programma’s mee geinstalleerd worden. Kortom, Ubuntu heeft afgedaan. Komende tijd maar eens op zoek naar een andere distributie.

Xs4all met Ekiga

Het heeft even geduurd, maar ik heb het werkend gekregen. Eerder had Henk het al werkend voor accounts via Ekiga. De regel in het modem heb ik toegevoegd, echter het werkte nog steeds niet voor mijn voip account bij Xs4all. Blijkt dus dat ik poort 5060 moet openzetten:

> Connection unbind  application=SIP port=5060
> Saveall

Nu had ik dat al een keer eerder gedaan, maar door de firmware upgrade was die wijziging weer ongedaan gemaakt. Kortom, zowel het in- als uitbellen werkt nu!

Toevoeging 08-06-2008 14:45

Te vroeg gejuicht, het was slechts eenmalig. Het heeft gewerkt, maar zonder dat er iets is aangepast werkt het opeens niet meer en nergens is ook maar iets terug te vinden waarom het niet werkt. Het moet iets in Ubuntu zijn, want onder Vista met de webphone kan ik zonder problemen gebeld worden.

Herinstallatie voor Vista sp1

Mijn eerdere pogingen om sp1 te installeren op een HP laptop zijn hopeloos mislukt. Nu zou ik wel zonder sp1 kunnen, ware het niet dat na het verwijderen van sp1 de netwerkkaart nog steeds niet werkte. Er zat dus niets anders op dan de laptop opnieuw te installeren. Verrassend genoeg kon ik nu wel zonder problemen sp1 installeren.

Nu heb ik helaas alleen een recovery cd en geen volledige installatie dvd. Ik zit dus vast aan de vervuilde installatie die HP standaard levert. In totaal heeft het toch een hele avond gekost om alle troep op te ruimen en de instellingen te zetten zoals ik ze wil. Maar eens zien hoe ik makkelijk een image kan maken van de huidige installatie.

Vista sp1

Vorige week was het dan zover, service pack 1 van Vista werd via windows update aangeboden op mijn Hewlett-Packard laptop. Natuurlijk heb ik gelijk aangegeven dat ik die wou hebben. Ongeveer een uurtje later was het geheel klaar en kon ik inloggen.

Alleen jammer dat de netwerkverbinding totaal niet meer werkt. Ben nu al enkele dagen bezig om te achterhalen waar het door komt, maar ik ben nog geen steek verder. Het is geen driverprobleem, heb de nieuwste drivers gedownload voor zowel de normale netwerkkaart als de draadloze en deze werken perfect zonder dat sp1 geinstalleerd is.

Kortom, ik denk dat ik sp1 maar oversla. Ik ben helemaal bij met de security updates, dus daarvoor heb ik sp1 niet nodig. Het zit me alleen niet lekker dat ik de oorzaak niet heb kunnen vinden.

Toevoeging 11-05-2008 22:42

Ik ben er inmiddels achter dat het aan de sstp-service ligt. Deze kan niet worden gestart omdat er een bestand mist. Helaas vertelt windows er niet bij welk bestand mist. Het wordt dus zoeken naar de spreekwoordelijke speld in de hooiberg die Vista heet.